import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*([^\\{]+)\\s*\\{\\s*([^\\}]*?)\\s*\\}";
final String string = "body {background-color: red; }\n\n"
+ "td .vanilla {background-color: blue;}\n\n"
+ "td .vanilla {\n"
+ " color: red;\n"
+ " bg: \"wat\";\n"
+ " how: 'bout-that';\n"
+ "}\n\n"
+ "td \n"
+ ".vanilla {\n"
+ " color: red;\n"
+ " bg: wat;\n"
+ " how: 'bout-that';\n"
+ "}\n\n"
+ ".name { color:green; }\n\n"
+ ".dingus-mcgood{aye:yo;}\n\n"
+ " .wat{test:me}\n\n"
+ "#another { key : val ; }\n"
+ "#another { key : val }\n"
+ "#another{key:val;}\n\n"
+ "@media only screen and (max-width: 500px) {\n"
+ " body {\n"
+ " background-color: lightblue;\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}