// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\s*([^{]+)\s*\{\s*([^}]*?)\s*}").unwrap();
let string = "body {background-color: red; }
td .vanilla {background-color: blue;}
td .vanilla {
color: red;
bg: \"wat\";
how: 'bout-that';
}
td
.vanilla {
color: red;
bg: wat;
how: 'bout-that';
}
.name { color:green; }
.dingus-mcgood{aye:yo;}
.wat{test:me}
#another { key : val ; }
#another { key : val }
#another{key:val;}
@media only screen and (max-width: 500px) {
body {
background-color: lightblue;
}
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}