import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?\\:\\/\\/.+?\\.webm)\\h";
final String string = "waka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm waka";
final String subst = "<video width=\"320\" height=\"240\" controls><source src=\"$1\" type=\"video/webm\"></video>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}