import Foundation
let pattern = #"(https?\:\/\/.+?\.webm)\h"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"waka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm waka"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<video width="320" height="240" controls><source src="$1" type="video/webm"></video>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)