$re = '/(https?\:\/\/.+?\.webm)\h/';
$str = 'waka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm waka';
$subst = "<video width=\"320\" height=\"240\" controls><source src=\"$1\" type=\"video/webm\"></video>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;