// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(https?\:\/\/.+?\.webm)\h").unwrap();
let string = "waka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm waka";
let substitution = "<video width=\"320\" height=\"240\" controls><source src=\"$1\" type=\"video/webm\"></video>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}