use strict;
my $str = 'waka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm waka';
my $regex = qr/(https?\:\/\/.+?\.webm)\h/p;
my $subst = '<video width="320" height="240" controls><source src="$1" type="video/webm"></video>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";