const regex = /(https?\:\/\/.+?\.webm)\h/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https?\\:\\\/\\\/.+?\\.webm)\\h', 'g')
const str = `waka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm wakawaka http://video.webmfiles.org/big-buck-bunny_trailer.webm waka`;
const subst = `<video width="320" height="240" controls><source src="$1" type="video/webm"></video>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);