# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/('[^']*?(?:\\'[^']*?)*'|[^\s]+)/**`$1`**,/gi;t' <<< "Discerning between 'the single quote\'s double purpose' as a 'quote marker', like \", and a 'a cotraction\'s marker.'.
If you asked the author and he was speaking in the third person, he would say 'CFQueryParam\'s example is contrived, and he knew that but he had the world\'s most difficult time thinking up an example.'"