// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)('[^']*?(?:\\'[^']*?)*'|[^\s]+)").unwrap();
let string = "Discerning between 'the single quote\\'s double purpose' as a 'quote marker', like \", and a 'a cotraction\\'s marker.'.
If you asked the author and he was speaking in the third person, he would say 'CFQueryParam\\'s example is contrived, and he knew that but he had the world\\'s most difficult time thinking up an example.'";
let substitution = "**`$1`**,";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}