import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "('[^']*?(?:\\\\'[^']*?)*'|[^\\s]+)";
final String string = "Discerning between 'the single quote\\'s double purpose' as a 'quote marker', like \", and a 'a cotraction\\'s marker.'.\n\n"
+ "If you asked the author and he was speaking in the third person, he would say 'CFQueryParam\\'s example is contrived, and he knew that but he had the world\\'s most difficult time thinking up an example.'";
final String subst = "**`$1`**,";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}