re = /('[^']*?(?:\\'[^']*?)*'|[^\s]+)/i
str = 'Discerning between \'the single quote\\\'s double purpose\' as a \'quote marker\', like ", and a \'a cotraction\\\'s marker.\'.
If you asked the author and he was speaking in the third person, he would say \'CFQueryParam\\\'s example is contrived, and he knew that but he had the world\\\'s most difficult time thinking up an example.\''
subst = '**`$1`**,'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result