using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"('[^']*?(?:\\'[^']*?)*'|[^\s]+)";
string substitution = @"**`$1`**,";
string input = @"Discerning between 'the single quote\'s double purpose' as a 'quote marker', like "", and a 'a cotraction\'s marker.'.
If you asked the author and he was speaking in the third person, he would say 'CFQueryParam\'s example is contrived, and he knew that but he had the world\'s most difficult time thinking up an example.'";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}