const regex = /('[^']*?(?:\\'[^']*?)*'|[^\s]+)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\'[^\']*?(?:\\\\\'[^\']*?)*\'|[^\\s]+)', 'gi')
const str = `Discerning between 'the single quote\\'s double purpose' as a 'quote marker', like ", and a 'a cotraction\\'s marker.'.
If you asked the author and he was speaking in the third person, he would say 'CFQueryParam\\'s example is contrived, and he knew that but he had the world\\'s most difficult time thinking up an example.'`;
const subst = `**\`$1\`**,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);