#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)Cars(?>\.(?!select)\w+(?:\([^)]*\))?\s*)+\;"
Local $sString = "Cars.Items()" & @CRLF & _
" .Where(x => x.Year == "1988")" & @CRLF & _
" .Select(x => new { x.Registration })" & @CRLF & _
" .ToList();" & @CRLF & _
"" & @CRLF & _
"Cars.Items()" & @CRLF & _
" .Where(x => x.Id == 1923984)" & @CRLF & _
" .Select(x => new { x.Registration })" & @CRLF & _
" .FirstOrDefault;" & @CRLF & _
"" & @CRLF & _
"Cars.Items().Where(x => x.Id == 1923984).FirstOrDefault;" & @CRLF & _
"" & @CRLF & _
"Cars.Items();" & @CRLF & _
"" & @CRLF & _
"Cars.Items()" & @CRLF & _
".GroupBy(g => g.Key)" & @CRLF & _
".First();"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")