const regex = /Cars(?>\.(?!select)\w+(?:\([^)]*\))?\s*)+\;/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Cars(?>\\.(?!select)\\w+(?:\\([^)]*\\))?\\s*)+\\;', 'gi')
const str = `Cars.Items()
.Where(x => x.Year == "1988")
.Select(x => new { x.Registration })
.ToList();
Cars.Items()
.Where(x => x.Id == 1923984)
.Select(x => new { x.Registration })
.FirstOrDefault;
Cars.Items().Where(x => x.Id == 1923984).FirstOrDefault;
Cars.Items();
Cars.Items()
.GroupBy(g => g.Key)
.First();`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}