# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Cars(?>\.(?!select)\w+(?:\([^)]*\))?\s*)+\;"
test_str = ("Cars.Items()\n"
" .Where(x => x.Year == \"1988\")\n"
" .Select(x => new { x.Registration })\n"
" .ToList();\n\n"
"Cars.Items()\n"
" .Where(x => x.Id == 1923984)\n"
" .Select(x => new { x.Registration })\n"
" .FirstOrDefault;\n\n"
"Cars.Items().Where(x => x.Id == 1923984).FirstOrDefault;\n\n"
"Cars.Items();\n\n"
"Cars.Items()\n"
".GroupBy(g => g.Key)\n"
".First();")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.