re = /Cars(?>\.(?!select)\w+(?:\([^)]*\))?\s*)+\;/i
str = 'Cars.Items()
.Where(x => x.Year == "1988")
.Select(x => new { x.Registration })
.ToList();
Cars.Items()
.Where(x => x.Id == 1923984)
.Select(x => new { x.Registration })
.FirstOrDefault;
Cars.Items().Where(x => x.Id == 1923984).FirstOrDefault;
Cars.Items();
Cars.Items()
.GroupBy(g => g.Key)
.First();'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end