use strict;
my $str = 'Cars.Items()
.Where(x => x.Year == "1988")
.Select(x => new { x.Registration })
.ToList();
Cars.Items()
.Where(x => x.Id == 1923984)
.Select(x => new { x.Registration })
.FirstOrDefault;
Cars.Items().Where(x => x.Id == 1923984).FirstOrDefault;
Cars.Items();
Cars.Items()
.GroupBy(g => g.Key)
.First();';
my $regex = qr/Cars(?>\.(?!select)\w+(?:\([^)]*\))?\s*)+\;/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}