using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Cars(?>\.(?!select)\w+(?:\([^)]*\))?\s*)+\;";
string input = @"Cars.Items()
.Where(x => x.Year == ""1988"")
.Select(x => new { x.Registration })
.ToList();
Cars.Items()
.Where(x => x.Id == 1923984)
.Select(x => new { x.Registration })
.FirstOrDefault;
Cars.Items().Where(x => x.Id == 1923984).FirstOrDefault;
Cars.Items();
Cars.Items()
.GroupBy(g => g.Key)
.First();";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}