#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?=\b([a-z]*a[a-z]*)).*\r?\n"
Local $sString = "Little Miss Muffet she sat" & @CRLF & _
"on her tuffet, eating" & @CRLF & _
"her curds" & @CRLF & _
" and whey. Along came a spider" & @CRLF & _
"who sat down beside her and" & @CRLF & _
"frightened Miss Muffet away" & @CRLF & _
"The end." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")