using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=\b([a-z]*a[a-z]*)).*\r?\n";
string input = @"Little Miss Muffet she sat
on her tuffet, eating
her curds
and whey. Along came a spider
who sat down beside her and
frightened Miss Muffet away
The end.
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}