import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=\\b([a-z]*a[a-z]*)).*\\r?\\n";
final String string = "Little Miss Muffet she sat\n"
+ "on her tuffet, eating\n"
+ "her curds\n"
+ " and whey. Along came a spider\n"
+ "who sat down beside her and\n"
+ "frightened Miss Muffet away\n"
+ "The end.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}