const regex = /(?=\b([a-z]*a[a-z]*)).*\r?\n/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=\\b([a-z]*a[a-z]*)).*\\r?\\n', 'gmi')
const str = `Little Miss Muffet she sat
on her tuffet, eating
her curds
and whey. Along came a spider
who sat down beside her and
frightened Miss Muffet away
The end.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}