use strict;
my $str = 'Little Miss Muffet she sat
on her tuffet, eating
her curds
and whey. Along came a spider
who sat down beside her and
frightened Miss Muffet away
The end.
';
my $regex = qr/(?=\b([a-z]*a[a-z]*)).*\r?\n/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}