import re
regex = re.compile(r"(?=\b([a-z]*a[a-z]*)).*\r?\n", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Little Miss Muffet she sat\n"
"on her tuffet, eating\n"
"her curds\n"
" and whey. Along came a spider\n"
"who sat down beside her and\n"
"frightened Miss Muffet away\n"
"The end.\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")