# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=regex\s)(.*)/\1/gms;t' <<< "
some text for test and need to replace by regex using php
we have extra sentence too"