$re = '/(?<=regex\s)(.*)/ms';
$str = '
some text for test and need to replace by regex using php
we have extra sentence too';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;