re = /(?<=regex\s)(.*)/m
str = '
some text for test and need to replace by regex using php
we have extra sentence too'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result