const regex = /(?<=regex\s)(.*)/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=regex\\s)(.*)', 'gms')
const str = `
some text for test and need to replace by regex using php
we have extra sentence too`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);