#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ms)(?<=regex\s)(.*)"
Local $sString = "" & @CRLF & _
"some text for test and need to replace by regex using php" & @CRLF & _
"" & @CRLF & _
"we have extra sentence too"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)