#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\/images\/(?<img>[^\/]+)(\/(?<width>\d*))?(\/(?<height>\d*))?$"
Local $sString = "/images/my.jpg" & @CRLF & _
"/images/my.jpg/200" & @CRLF & _
"/images/my.jpg/200/" & @CRLF & _
"/images/my.jpg/200/400" & @CRLF & _
"/images/my.jpg/200/400/"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)