use strict;
my $str = '/images/my.jpg
/images/my.jpg/200
/images/my.jpg/200/
/images/my.jpg/200/400
/images/my.jpg/200/400/';
my $regex = qr/\/images\/(?<img>[^\/]+)(\/(?<width>\d*))?(\/(?<height>\d*))?$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";