const regex = /\/images\/(?<img>[^\/]+)(\/(?<width>\d*))?(\/(?<height>\d*))?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/images\\\/(?<img>[^\\\/]+)(\\\/(?<width>\\d*))?(\\\/(?<height>\\d*))?$', 'gm')
const str = `/images/my.jpg
/images/my.jpg/200
/images/my.jpg/200/
/images/my.jpg/200/400
/images/my.jpg/200/400/`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);