$re = '/\/images\/(?<img>[^\/]+)(\/(?<width>\d*))?(\/(?<height>\d*))?$/m';
$str = '/images/my.jpg
/images/my.jpg/200
/images/my.jpg/200/
/images/my.jpg/200/400
/images/my.jpg/200/400/';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;