# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\/images\/(?<img>[^\/]+)(\/(?<width>\d*))?(\/(?<height>\d*))?$"
test_str = ("/images/my.jpg\n"
"/images/my.jpg/200\n"
"/images/my.jpg/200/\n"
"/images/my.jpg/200/400\n"
"/images/my.jpg/200/400/")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.