import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/images\\/(?<img>[^\\/]+)(\\/(?<width>\\d*))?(\\/(?<height>\\d*))?$";
final String string = "/images/my.jpg\n"
+ "/images/my.jpg/200\n"
+ "/images/my.jpg/200/\n"
+ "/images/my.jpg/200/400\n"
+ "/images/my.jpg/200/400/";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}