# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/,(?<!("|\\/|\\))(\b\d+\b)(?!("|\\/|\\|( \d)))/,"$2"/g;t' <<< "\"87\",0000,0767,\"078\",0785,\"0723\",23487, \"061 904 5284\",\"17\/10\/2016\",\"some.name.789@hotmail.com\""