$re = '/,(?<!("|\/|\\\\))(\b\d+\b)(?!("|\/|\\\\|( \d)))/';
$str = '"87",0000,0767,"078",0785,"0723",23487, "061 904 5284","17\\/10\\/2016","some.name.789@hotmail.com"';
$subst = ",\"$2\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;