import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ",(?<!(\"|\\/|\\\\))(\\b\\d+\\b)(?!(\"|\\/|\\\\|( \\d)))";
final String string = "\"87\",0000,0767,\"078\",0785,\"0723\",23487, \"061 904 5284\",\"17\\/10\\/2016\",\"some.name.789@hotmail.com\"";
final String subst = ",\"$2\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}