# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r",(?<!(\"|\/|\\))(\b\d+\b)(?!(\"|\/|\\|( \d)))"
test_str = "\"87\",0000,0767,\"078\",0785,\"0723\",23487, \"061 904 5284\",\"17\\/10\\/2016\",\"some.name.789@hotmail.com\""
subst = ",\"$2\""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.