import Foundation
let pattern = #",(?<!("|\/|\\))(\b\d+\b)(?!("|\/|\\|( \d)))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #""87",0000,0767,"078",0785,"0723",23487, "061 904 5284","17\/10\/2016","some.name.789@hotmail.com""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #","$2""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)