# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:(\d*|\D)*(\|)){4}\K/|]/;t' <<< "ID|CategoryID|Category|Title|Summary|Article
###|###|Business|4 Things I Wish I Knew Before Starting My Company|This is where the summary would go|This is where the article would begin"