using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(\d*|\D)*(\|)){4}\K";
string substitution = @"|]";
string input = @"ID|CategoryID|Category|Title|Summary|Article
###|###|Business|4 Things I Wish I Knew Before Starting My Company|This is where the summary would go|This is where the article would begin";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}