use strict;
my $str = 'ID|CategoryID|Category|Title|Summary|Article
###|###|Business|4 Things I Wish I Knew Before Starting My Company|This is where the summary would go|This is where the article would begin';
my $regex = qr/(?:(\d*|\D)*(\|)){4}\K/p;
my $subst = '|]';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";