import Foundation
let pattern = #"(?:(\d*|\D)*(\|)){4}\K"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ####"""
ID|CategoryID|Category|Title|Summary|Article
###|###|Business|4 Things I Wish I Knew Before Starting My Company|This is where the summary would go|This is where the article would begin
"""####
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"|]"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}