#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:(\d*|\D)*(\|)){4}\K"
Local $sString = "ID|CategoryID|Category|Title|Summary|Article" & @CRLF & _
"" & @CRLF & _
"###|###|Business|4 Things I Wish I Knew Before Starting My Company|This is where the summary would go|This is where the article would begin"
Local $sSubst = "|]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)