$re = '/(?:(\d*|\D)*(\|)){4}\K/';
$str = 'ID|CategoryID|Category|Title|Summary|Article
###|###|Business|4 Things I Wish I Knew Before Starting My Company|This is where the summary would go|This is where the article would begin';
$subst = "|]";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;