# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[\p{P} ]+//gu;t' <<< "@üsername
(@username)
@username:
@user — name"