use strict;
my $str = '@üsername
(@username)
@username:
@user — name';
my $regex = qr/[\p{P} ]+/up;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";